Degraded performance of pro-membership
Incident Report for Minibrew
Resolved
This incident has been resolved.
Posted Mar 02, 2023 - 16:44 CET
Investigating
We are aware of the issue and investigating it currently. It's based on multiple reports of users that have connecting issues
Posted Feb 27, 2023 - 11:15 CET
This incident affected: Cloud / Server (Server).